cannot install package “ggbiplot” on R 4.0

cannot install package “ggbiplot” on R 4.0

1

I tried to install package “ggbiplot” for R v4.0

library("devtools")
Sys.setenv(R_REMOTES_NO_ERRORS_FROM_WARNINGS="true") 
devtools::install_github("tidyverse/ggplot2")

it asks me to upgrade these packages and I allow it

enter image description here

but at the end it doesn’t install

* installing *source* package 'ggbiplot' ...
** using staged installation
** R
** data
** byte-compile and prepare package for lazy loading
Error: package or namespace load failed for 'ggplot2' in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
 namespace 'ellipsis' 0.3.1 is being loaded, but >= 0.3.2 is required
Error: package 'ggplot2' could not be loaded
In addition: Warning message:
package 'ggplot2' was built under R version 4.0.5 
Execution halted
ERROR: lazy loading failed for package 'ggbiplot'
* removing 'C:/Users/tahamim/Documents/R/win-library/4.0/ggbiplot'

* removing 'C:/Users/tahamim/Documents/R/win-library/4.0/ggbiplot'

I have closed my R and re-opned several times, but it didn’t fix the problem.


ggbiplot


R

• 30 views

updated 1 hour ago by

▴

120

written 2 hours ago by

▴

30

Read more here: Source link