Skingpt4 errors python – Models

warning libmamba Added empty dependency for problem type SOLVER_RULE_UPDATE
Could not solve for environment specs
The following packages are incompatible
├─ libzlib is installable and it requires
│ └─ zlib 1.2.13 _5, which can be installed;
├─ mamba is installable and it requires
│ └─ python_abi 3.11.
_cp311, which requires
│ └─ python 3.11.
*_cpython, which can be installed;
├─ python_abi, which can be installed (as previously explained);
├─ pytorch 2.0.0 is not installable because there are no viable options
│ ├─ pytorch 2.0.0 would require
│ │ └─ python >=3.10,<3.11.0a0 but there are no viable options
│ │ ├─ python [3.10.0|3.10.3|3.10.4] would require
│ │ │ └─ zlib >=1.2.11,<1.3.0a0 , which conflicts with any installable versions previously reported;
│ │ ├─ python [3.10.10|3.10.11|…|3.10.9] would require
│ │ │ └─ zlib >=1.2.13,<1.3.0a0 , which conflicts with any installable versions previously reported;
│ │ └─ python 3.10.6 would require
│ │ └─ zlib >=1.2.12,<1.3.0a0 , which conflicts with any installable versions previously reported;
│ ├─ pytorch 2.0.0 would require
│ │ └─ python >=3.8,<3.9.0a0 , which conflicts with any installable versions previously reported;
│ └─ pytorch 2.0.0 would require
│ └─ python >=3.9,<3.10.0a0 , which conflicts with any installable versions previously reported;
├─ torchaudio 2.0.0 is not installable because there are no viable options
│ ├─ torchaudio 2.0.0 would require
│ │ └─ python >=3.10,<3.11.0a0 , which cannot be installed (as previously explained);
│ ├─ torchaudio 2.0.0 would require
│ │ └─ python >=3.8,<3.9.0a0 , which conflicts with any installable versions previously reported;
│ └─ torchaudio 2.0.0 would require
│ └─ python >=3.9,<3.10.0a0 , which conflicts with any installable versions previously reported;
└─ torchvision 0.15.0 is not installable because there are no viable options
├─ torchvision 0.15.0 would require
│ └─ python >=3.10,<3.11.0a0 , which cannot be installed (as previously explained);
├─ torchvision 0.15.0 would require
│ └─ python >=3.8,<3.9.0a0 , which conflicts with any installable versions previously reported;
└─ torchvision 0.15.0 would require
└─ python >=3.9,<3.10.0a0 , which conflicts with any installable versions previously reported.

Read more here: Source link